Power & Source of Big Ideas

Mini2451 Serial Console

Moderators: chensy, FATechsupport

I've been developing on the Mini2440 for the past few years and recently started on the Mini2451.
On the Mini2440 the kernel messages was output on the serial port. On the Mini2451 there are no kernel messages on the serial port.

How do I enable the serial console?

I've set it in the boot options: Linux-CommandLine = root=/dev/mtdblock2 rootfstype=yaffs2 init=/linuxrc console=ttySAC0,115200 vt.global_cursor_default=0

And also added it to the kernel configuration in boot options. But still no output.

Thanks in advance.
Anyone got any ideas?
Hi bluescape,

Long time no hear. Don't work on the FA stuff any more so don't check-in very often.

What distro are you running on the Mini2451? I used the process as described on the Armworks site.

To your problem ... the only thing I can suggest is checking the attributes at /dev/ttySAC0

I ran an LCD on mine with the following bootargs:

Code: Select all

root=/dev/mmcblk0p2 rootfstype=ext4 init=/sbin/init console=ttySAC0,115200 lcd=S70

Good luck.


Who is online

In total there are 3 users online :: 0 registered, 0 hidden and 3 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 3 guests