I got a Mini2440 board with an Intellimetrix "Embedded LInux" course some time back and I want to get it going again.
They had me set up a virtual machine running Fedora within a Windows machine. In Fedora, I created an NFS server and the Mini2440 boots from that just fine. It still works today.

I now want to lose the virtual machine and develop from a dedicated Ubuntu 18 machine. I've created what appears to be an identical NFS server on the Ubuntu machine yet the Mini2440 will not boot from it. From a second Ubuntu machine, I can mount both the Fedora NFS server and the Ubuntu NFS server using identical commands (one on the network at at time since I have both machines configured at the same static IP address) and both seem to work identically. However, the Mini2440 will only boot from the Fedora NFS server; not the Ubuntu NFS server.

I've tried everything I can think of with no luck. I've tried:
Forcing NFSv3 - no difference. Found that working Fedora uses NFSv4 anyway.
Disabling apparmor - no difference. apparmor is similar to SELinux found on Fedora.

What am I missing?