Power & Source of Big Ideas

Nanopi R1

Moderators: chensy, FATechsupport


any advise for build openwrt for nanopi r1?

I downloaded and do make menuconfig, but i cant see nanopi r1 hardware.

Thanks a lot
from where did you "git clone"?
for the other NanoPi's are here the instructions:
http://wiki.friendlyarm.com/wiki/index. ... ld_OpenWrt

or download compiled OpenWRT (SD or eflasher) from here:
https://drive.google.com/drive/folders/ ... GkfijH0frC
Thanks @guidol for your answer

I read the wiki and download from:

git clone https://github.com/friendlyarm/openwrt -b master-v18.06.1

make menuconfig

But, in the tarjet devices to compile only exist Allwiner A1/A20/A3x, so cant compile for H3, Im tried o with:

./build.sh nanopi-h3

And no build for nanopi R1,

Any help to compile for Nanopi R1?

how about

https://drive.google.com/open?id=1PHtHL ... 2Ss8ezgXDf

https://drive.google.com/open?id=1Bt2YV ... pFrMh3dRbb

https://drive.google.com/open?id=1I-ziR ... cbHtbbXvzC
Hello guidol,

Thanks a lot for your advices, I explain better my need, I want use the Nanopi R1 for a project with Openwrt, so I need build with my files and packages.

I have some experience on Openwrt development projects.

I tried

https://drive.google.com/open?id=1PHtHL ... 2Ss8ezgXDf

And following the directions in:

http://wiki.friendlyarm.com/wiki/index. ... ld_OpenWrt

But in all the cases cant find the target device Nanopi R1 or H3 architecture for build from sources Openwrt.

Only can build for nanopi-neo and nanopi-m1-plus, here the files generated:


I apreciate any help.


Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 102 on Mon Oct 08, 2018 12:42 pm

Users browsing this forum: No registered users and 1 guest