Page 1 of 1

Android Reboot Loop with 7" LCD attached

Posted: Fri Apr 29, 2016 5:05 pm
by kconger
Hi,

I'm having trouble flashing a working Android image on my Nanopi2 with 7"LCD

I flashed the newest image on GDrive using dd. When I boot the nanopi2 I see the friendlyarm logo flash on and off on my 7" LCD. Watching over serial I don't see a crash in the kernel, I just see it suddenly go back to the uboot prompt then start booting the kernel again.

Re: Android Image Flashing

Posted: Tue May 03, 2016 5:28 pm
by kconger
Answering my own question incase it helps others.

The problem was that the provided power supply isn't sufficient to power the LCD and board at the same time. I replaced with my RPi3 power supply and all is well.

Re: Android Reboot Loop with 7" LCD attached

Posted: Thu May 05, 2016 8:47 am
by FATechsupport
A stable 5V/2A power supply is a must.

Re: Android Reboot Loop with 7" LCD attached

Posted: Thu May 05, 2016 1:56 pm
by kconger
I would just expect FriendlyArm to have included one with the nanopi2/lcd combo I purchased. The one I received wasn't. Just an FYI to anyone else who purchases the NanoPi2/LCD/Power supply package.

Re: Android Reboot Loop with 7" LCD attached

Posted: Tue May 10, 2016 10:27 am
by FATechsupport

Re: Android Reboot Loop with 7" LCD attached

Posted: Mon Aug 08, 2016 3:27 am
by wirog80
hi all,
i have bought NanoPi2 and NanoPi2 Fire
i'm using this PSU power supply : http://www.friendlyarm.com/index.php?route=product/product&path=73&product_id=127

for NanoPi2 :
if i plug in to micro USB socket, reboot loop is happened
but if i plug in to power pins from GPIO (VCC & GND), it's boot normally and running well.

for NanoPi2 Fire:
if i plug in to micro USB socket, just once boot shown FriendlyARM logo only and then the LCD is blank and 2 LED on the board is off.
same case for plug in to power pins.

i'm using this image for both board :s5p4418-android-sd4g-20160629.img

any solution?
sorry for my English :)
thanks

Re: Android Reboot Loop with 7" LCD attached

Posted: Fri Apr 06, 2018 9:01 am
by maintec
Hello.
I have the same problem with a nanopi2 fire. I am using a power supply with 3 A of maximum output current. In attachment you can find the boot log. Can you check it ?

Re: Android Reboot Loop with 7" LCD attached

Posted: Sat Dec 01, 2018 1:40 pm
by ScottFiore
kconger wrote:
Hi,

I'm having trouble flashing a working Android image on my Nanopi2 with 7"LCD

I flashed the newest image on GDrive using dd. When I boot the nanopi2 I see the friendlyarm logo flash on and off on my 7" LCD. .


A stable 5V/2A power supply is a must. ;) ;)

Re: Android Reboot Loop with 7" LCD attached

Posted: Wed Dec 05, 2018 12:40 pm
by negan16
I have the same problem too and yet I use a power supply. a solution please?

______________________________________________________________________
UC Browser SHAREit MX Player