Power & Source of Big Ideas

[SOLVED] NANO PI M2A Sound Not Working on Debian ??

Moderators: chensy, FATechsupport

Hello all, I have a brand new NANO PI M2A board. I burned the Debian Jessie Image as instructed,
and it works real nice.

Unfortunately I can't get any audio from it, nor from the audio jack or from the HDMI.

I followed the instructions as per the Wiki, installing the alsa packages

apt-get update
apt-get install libasound2
apt-get install alsa-base
apt-get install alsa-utils

then adding the file /etc/asound.conf (wasn't there)

pcm.!default {
type hw
card 0
device 0

ctl.!default {
type hw
card 0

I tried both 0 and 1 for the card line and rebooting each time, but nothing.

when I run aplay -L I get:

Discard all samples (playback) or generate zero samples (capture)
Default Audio Device
Direct sample mixing device
Direct sample snooping device
Direct hardware device without any conversions
Hardware device with all software conversions
Default Audio Device
Direct sample mixing device
Direct sample snooping device
Direct hardware device without any conversions
Hardware device with all software conversions

which means it sees the audio modules

But when I run speaker-test, It can't use the channel:

speaker-test 1.0.28

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Channels count (1) not available for playbacks: Invalid argument
Setting of hwparams failed: Invalid argument

I've tried a few other things but the channel is never available for playback, with the speaker test or the media programs. Heck, I can't even place a volume control on the LX panel, it won't do it.

I wonder If anyone out there has made the audio work with the 4418 NP M2 or M2A, I appreciate any help in advance!
Hopefully someone from FriendlyArm can lend a hand so we can get the system to run as advertised. This is the second type board I buy from FA and I would regret to hit another wall like this on my project.

Thanks again!
Ok I was being misled by a couple of things

On the speaker test command, the c option was necessary to specify the number of channels, in this case 2 since the DAC and audio jack are stereo, so this worked:

speaker-test -c 2

Alnd to play some of the .wavs with aplayer, you must specify the plughw type so it can convert the sampling format.
This works:

aplay --device plughw:CARD=I2SES8316,DEV=0 test.wav

And I was also testing some of the .wavs with the GUI smplayer program, but it was't playing them because in smplayer you have to manually select your 'card':
Go to Options->Preferences->audio->output driver, select alsa 0.0 I2SES8316 for the audio jack output

Also tested Youtube on Firefox and it works without adjustments

So audio works on the 3.5mm Jack, what a fantastic board so far so good.

Now I could not get the HDMI audio to work on any of the files or programs after changing to 'card 1' on asound.conf
aplayer and smplayer both say they're playing the wav but nothing comes out. I'm hooked up to a tv by the way.
I don't need HDMI audio for my project so this will go to the back burner for now. I'll post if I find a solution later.


https://askubuntu.com/questions/225445/ ... -any-sound
https://forum.voidlinux.eu/t/solved-als ... ble/674/10
https://unix.stackexchange.com/question ... ard-to-use

Who is online

In total there are 3 users online :: 0 registered, 0 hidden and 3 guests (based on users active over the past 5 minutes)
Most users ever online was 5185 on Wed Jan 22, 2020 1:44 pm

Users browsing this forum: No registered users and 3 guests