Power & Source of Big Ideas

hardware accelerated encode h.264 on NanoPi 2

Moderators: chensy, FATechsupport

I am trying to use ffmpeg on nanopi2 for streaming h.264 (640x480 only with webcam (yuyv422 or mjpeg output)) but i don't know where to find or don't know how to enable the hardware accelerator for it
(etc: vaapi). Software encode is very slow, I just get less than 5 fps for full cpu processing time.

I would like to know is there any way to stream 640x480 video very smoothly and no bandwidth problem?
Hi
I had same experience , both ffmpeg and ffplay seems to have problem, but the problem refer to the SD card.
If the OS executed on an SD card , you can not play high definition videos. even there is a 720 p video in the
Videos directory , when you play with normal size no problem appears but as soon as resize it to full screen
it will be played much slower !
Another test I made was putting the media on a usb flash but no result.

seems that the hdmi port on a SD card HDD architecture for H.264 purpose isn`t true.
meisam wrote:
Hi
I had same experience , both ffmpeg and ffplay seems to have problem, but the problem refer to the SD card.
If the OS executed on an SD card , you can not play high definition videos. even there is a 720 p video in the
Videos directory , when you play with normal size no problem appears but as soon as resize it to full screen
it will be played much slower !
Another test I made was putting the media on a usb flash but no result.

seems that the hdmi port on a SD card HDD architecture for H.264 purpose isn`t true.



I'm just using a webcam, for 640x480 streaming. But still it doesn't works at all, I think it because the hardware decoder is not apply. I'm streaming mjpeg with no problem.
larryho5 wrote:


I'm just using a webcam, for 640x480 streaming. But still it doesn't works at all, I think it because the hardware decoder is not apply. I'm streaming mjpeg with no problem.



FFMpeg uses H264 and H265 libs with no using your GPU ! if you play the stream it will uses GPU.
The problem is when you want to play. Check it please your self.

You can set Video setting in the SMPlayer or VLC through preferences menu. I have checked all but no result.

Who is online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 2865 on Sun Nov 10, 2019 5:27 am

Users browsing this forum: No registered users and 4 guests