Page 1 of 1

Fusing Debian problem

Posted: Sun Jan 17, 2016 9:55 am
by davef
I tried to flash a microSD card with the Debian image and get the following error:

Error: /dev/sdb is non-removable device. Stop.

After looking through I had a look at the contents of the file:


and find the character 0

I checked all my SD cards and they all say removeable is a 0

Am I over-looking something quite basic here?

Re: Fusing Debian problem

Posted: Mon Jan 18, 2016 2:06 am
by davef
Added LINUX pmount on the host:

apt-get install pmount

and in /etc/pmount.allow added:


no luck, then added


still no luck.

Am I correct in assuming that a 32-bit Linux host is adequate for everything except compiling your own programs using arm-cortexa9-linux-gnueabihf-4.9.3?

Re: Fusing Debian problem

Posted: Mon Jan 18, 2016 10:21 am
by FATechsupport

This may be caused by your 32 bit OS or your card reader. The "tools/sd_update" is for a 64-bit OS. We added this check "/sys/block/sdb/removeable" in the script in order to prevent users from writing his hard disk accidentally.

In your case you may try removing this restriction in the script and try again.

Re: Fusing Debian problem

Posted: Mon Jan 18, 2016 5:52 pm
by davef
I had already tried removing those lines in, but then that script asks you to download the debian image. As I had already downloaded the image I wanted (as suggested earlier in the Wiki document) I would not expect to have to download it again.

I am currently in a remote location with limited internet access and can not download it again. So, I flashed the card using Windows.

I am having fun exploring the capabilities of the image you provided.