Latest image 16.04 Lubuntu for Nanopi M2 has a problem once upgraded via 'apt update' where snapd service is not running.
The error from journalctl -xe is :

Aug 20 14:23:19 FriendlyELEC snapd[2162]: error: cannot start snapd: cannot mount squashfs image using "squashfs": mount: unknown filesystem type 'squashfs'

It looks like squashfs is not in the kernel compilation. I have to disable snapd for the system to function correctly
.
Also DTB for M2 still has not been added to Nanopi images !