Power & Source of Big Ideas

NanoPI M2 has garbage on serial console from kernel

Moderators: chensy, FATechsupport

Hi,
U-Boot is show ok, but as soon as kernel starts it shows block graphic characters (always the same).
Does not look like a wrong baudrate. With scope I see the bits have correct length for 115K2.
This happens on all kernels I compile myself Linux and Android.
The Linux kernel from your image is fine, so I assume it is a kernel config issue.
The android kernel from your image also shows the garbage.

It would help to have the working .config file.
Thanks a lot.

PS: I tried different terminal programs on Ubuntu and Win7. Also tried different Serial/USB adapters.
Kernel cmd line in U-Boot looks good and kernel is configured to prefer the provided cmd line.
You may try our latest files from here:
https://www.mediafire.com/folder/ilkcy3 ... noPi2Board

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 2865 on Sun Nov 10, 2019 5:27 am

Users browsing this forum: No registered users and 1 guest