Power & Source of Big Ideas

Thrown out on SSH login

Moderators: chensy, FATechsupport

I'm trying to log into a NanoPi 2 for the first time. Have written nanopi2-debian-sd4g-wifiap.img to a 16G SanDisk card, and powering it through the micro-USB port. So far so good, I see the access point, and can attach to it.

When I connect via "ssh -l root 192.168.8.1" with password "fa", it seems to accept, but then throws me out:

packet_write_wait: Connection to 192.168.8.1: Broken pipe

In verbose mode, I see this (initial part omitted):

Code: Select all

debug1: Authentications that can continue: publickey,password
debug1: Trying private key: /Users/jcw/.ssh/id_dsa
debug1: Trying private key: /Users/jcw/.ssh/id_ecdsa
debug1: Trying private key: /Users/jcw/.ssh/id_ed25519
debug1: Next authentication method: password
root@192.168.8.1's password:
debug1: Authentication succeeded (password).
Authenticated to 192.168.8.1 ([192.168.8.1]:22).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
packet_write_wait: Connection to 192.168.8.1: Broken pipe


Is there a way to get past this problem? This is my first attempt ever to try out the NanoPi 2.

-jcw
Hi what terminal did you login to your Pi 2 from? We tried that from a host running Ubuntu 14.04 and it worked. Since this was a communication process between your terminal and the Pi 2 we suspect that this issue might be associated with your terminal.

Who is online

In total there are 10 users online :: 0 registered, 0 hidden and 10 guests (based on users active over the past 5 minutes)
Most users ever online was 825 on Wed Aug 28, 2019 3:18 pm

Users browsing this forum: No registered users and 10 guests