I was trying to connect a bluetooth keyboard to the NanoPi S2 but is not working at all.

I'm using Debian and used the bluetoothctl to make the connection. According to the outputs everything is working. However, when i trying to type or move the mouse, nothing happens in the screen.

According to hcitool the link is established and there is data exchange.

Code: Select all

root@NanoPi2:~# hcitool con
        < ACL D6:7D:57:A5:AD:FE handle 12 state 1 lm MASTER AUTH ENCRYPT
root@NanoPi2:~# hcitool lq
lq: too few arguments (minimal: 1)
        lq <bdaddr>
root@NanoPi2:~# hcitool lq D6:7D:57:A5:AD:FE
Link quality: 190
root@NanoPi2:~# hcitool info
info: too few arguments (minimal: 1)
        info <bdaddr>
root@NanoPi2:~# hcitool info D6:7D:57:A5:AD:FE
Requesting information ...
        BD Address:  D6:7D:57:A5:AD:FE
        Device Name: Bluetooth  Keyboard
        LMP Version: 2.1 (0x4) LMP Subversion: 0x2232
        Manufacturer: Airoha Technology Corp. (148)
        Features page 0: 0xfc 0x02 0x04 0x38 0x18 0x18 0x19 0x83
                <encryption> <slot offset> <timing accuracy> <role switch>
                <hold mode> <sniff mode> <RSSI> <power control>
                <enhanced iscan> <interlaced iscan> <interlaced pscan>
                <AFH cap. slave> <AFH class. slave> <AFH cap. master>
                <AFH class. master> <extended inquiry> <simple pairing>
                <encapsulated PDU> <LSTO> <inquiry TX power>
                <extended features>
        Features page 1: 0x01 0x00 0x00 0x00 0x00 0x00 0x00 0x00
root@NanoPi2:~# hcitool name D6:7D:57:A5:AD:FE
Bluetooth  Keyboard

I tried installing bluemon and with the GUI make the connection, same result, it shows activity and data exchange but nothing is happening in the screen.

I test the keyboard in a different computer and it works perfectly.

Do I missing something?

Thanks in advance