Power & Source of Big Ideas

Another update! Download new image or via apt update ; apt upgrade

Kernel update to 4.14.116

More info:
https://twitter.com/armbian/status/1124592076962836480
> with 2.4A rated microUSB charging cable. That means nothing. Read (and you will see the problem trough different perspective): https://forum.armbian.com/topic/4767-powering-through-micro-usb/ When you power via mUSB you have to be suspicious about it. All the time. It's crap and if it works on Rpi...
How about changing powering cables and power supply? Have you tried that?
Try to install it again. apt-get will soon tell you if it is on your device. If it doesn't appear try apt-get install dctrl-tools and DigitalOcean SiteGround iPage then I'll give you some commands to run I install the new package in Debian OS then reboot to boards. boot up to OS not see the package...
Hi igorp, Thanks for your reply. I've read thru several pages of the link you supplied but couldn't find anything on obtaining logs serially. Any other links I could look at? Anyway, I will try some of the other suggestions. Thanks again. Cheers Brett You need a serial console which you attach to s...
Is my new M4 faulty? Just received the following hardware from Friendly Arm: NanoPi M4 (2 GB) SanDisk 16GB EDGE A1 U1 Class 10 Micro SD SDHC MicroSD Memory Card 4 Amp power adapter Heatsink However, I cannot boot the damn thing up. When I plug the power supply in, the red LED goes solidly on, and t...
Hi, i just got the NEO4 and compared to RPI its slow.. really slow.. im running FriendlyDesktop.. Have tested my SD card and speed is 30MB / s can i somehow tweek this deviceso its faster!? and CPU usage is pretty low Perhaps you don't know how to properly compare? Check this: https://github.com/Th...
It does work on the Debian Image from Armbian According to this: https://forum.armbian.com/topic/9009-info-friendlyarm-pcm5102a-hat-with-nanopi-neo-under-mainline-4xx/ it works. I don't have this hat to test. I tried these steps with modification for Neo2 but couldn't get it to work. If someone got...
The following commands allow me to use IP-over-USB instead of a serial connection: su modprobe -r g_mass_storage modprobe g_cdc ifconfig usb0 netmask 255.255.255.0 192.168.13.2 However, I'm not sure how to cause this to happen a boot time. I use Raspbian and Gentoo, but I've never used sun8xi befor...
It does work on the Debian Image from Armbian According to this: https://forum.armbian.com/topic/9009-info-friendlyarm-pcm5102a-hat-with-nanopi-neo-under-mainline-4xx/ it works. I don't have this hat to test. but I cannot get it to install on the Ubuntu Image. That is the main reason why Armbian co...
I am unable to either install or compile squeezebox server. I tried both builds, the 4.X and 3.X and even the DietPi image. When I try to run squeezeboxserver I get the following error message: The following modules failed to load: DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::...
Dear all , I would suggest everyone to share his experience with M.2 SSD recognizable by NanoPC-T4 . From internet I found that these models should work: LITEON T10 120GB SSD Samsung MZ-V7E2T0BW SSD 970 EVO From my personal experience: "shorty" Toshiba KBG30ZMS256GA is not recognized by T...
Dear all , I would suggest everyone to share his experience with M.2 SSD recognizable by NanoPC-T4 . From internet I found that these models should work: LITEON T10 120GB SSD Samsung MZ-V7E2T0BW SSD 970 EVO From my personal experience: "shorty" Toshiba KBG30ZMS256GA is not recognized by T...
mackowiakp wrote:
Yes, I know that zRAM is available by default. But how can I configure this?


By editing /etc/default/armbian-zram-config

https://github.com/armbian/build/blob/m ... .dpkg-dist
mackowiakp wrote:
Because my nanoPi NEO has only 256 MB RAM, I want to create compressed ramdisk uzing zRAM feature (not for SWAP). It is possible as I know in Ubuntu but how can I do it on Xenial taken from Friendly Elec ?


This comes with Armbian by default.
dvoeckler wrote:
Hello FriendlyElec,

maybe any response? Ideas? Tipps?


Perhaps try https://www.armbian.com/nanopi-fire3/
It comes with more recent kernel and many additional fixes.
Hi, I have tried the out the old kernel you mentioned. In this case g_ether is also missing according to modproble. Is there a manual way to add g_ether? I did not find g_ether mentioned in the Armbian documentation. Armbian documentation does not cover all possible kernel related functions. For th...
from that statement it would seem "All non-armbian users are wrong." ...well....thanks anyway.... Undo my relation to Armbian and think, explore and make your own conclusion based on science, facts. There was a lot of research on this topic and if you would invest some time to find that, ...
MIPI camera support should also work since we use the same kernel (default images) with a few fixes. it's not working, since RkISP and both camera sensor drivers, which can be used with NanoPi T/M/Neo 4 (ov13xx and ov46xx) disabled by default. (so user need to recompile kernel). the bigger problem ...
LTolledo wrote:
has support/updates/bugfixes...


Nope. It doesn't. Debian packages update is irrelevant.

It's demo/proof of concept image and (Dietpi) is a rebranding (with some user space mods) of the same creation. Without any low level change.

Yes, you have all rights to be wrong :)
Update: Just a final test before actually giving up, I did try to install UbuntuCore from the Friendly Elec software download section and after installing checked the max CPU freq using lscpu ~# lscpu Architecture: aarch64 Byte Order: Little Endian CPU(s): 4 On-line CPU(s) list: 0-3 Thread(s) per c...
Good day! I've had the Nanopi Neo2 v1.0 for sometime now, used for mostly for NAS solution. the v1.0 is the one being carried by my supplier here. No v1.1 yet Lately I installed armbian monitor to monitor system resources. Then I stumbled upon the min and max frequency when I checked using # cpufre...
Armbian supports Docker OOB.

Wifi works on M4 and MIPI camera support should also work since we use the same kernel (default images) with a few fixes.
JAGITA wrote:
I would like to purchase this WiFi Transciever on Mouser


But it will not work.
super64 wrote:
Sorry, my fault. I forgot to say I have an M4. Thanks again.


OK. Sadly we haven't found this hack for M4 yet :(
ISTANBUL wrote:
Hi,

I back up my eMMc to usb . ıts almost 15 Gig. And today I want to back to my backup . I restoring that file from usb, rebooting from eMMc but all black screen and blinking yellow led.

What can I do ? any help ?


Thanks


And how did you made a backup?
I was booting Armbian off the eMMC but I want to now boot off SD card. How do I change the boot device? I put an SD card in with bootable OS but with just an SD card in, the NanoPi just flashes the green LED. Thanks T4 has a button which you need to hold to force booting from SD card. Button shorts...
Jill D Holloman wrote:
Does the NanoPi NEO support DHT22 temperature-humidity sensor connected via 1wire bus?

I use the DHT22 sensors on my Raspi2, they work fine.

Thank you.


https://forum.armbian.com/search/?q=1wire&fromCSE=1
OK. But I have no choice. Just 120 measuring units with FriendlyElec Linux distro on it. No way to change to another distro. Why? You will burn 120 cards faster and you will not need to use any brain power for that operation. All optimisations are implemented here https://github.com/armbian/build b...
I have more then 100 pcs nanoPi NEO already installed and solder inside measuring units, with several sensor connected to each one. Because most of them has only 256 MB RAM, I must to increase amount of memory. I use Linux distro from Friendly Elec. It is not possible to solder something in already...
OK, thank you for these links. I actually tried 4.19.20, but g_ether did not work. Does it matter if I use bionic or stretch download. As it was not working on Armbian, I ask in their forum and received as answer that it doesn't work: https://forum.armbian.com/topic/9530-nano-pi-neo-air-ssh-using-u...
Hi, I would like to know if someone was able to use g_ether on the NanoPi Neo Air. It is very important for me to be able to connect via ethernet to the NanoPi Neo Air using the USB interface (the micro usb port, not using the other usb interfaces on the 2,54mm headers). I have tried Armbian and th...
If you are using their sources I can't help. No idea how they put their images together ... this is ARM, there are not much standard solution and GRUB is not used at all. If you use our build system https://github.com/armbian/build kernel packages made that way are installed with dpkg -i u-boot_or_k...
Hi, I am running Armbian Bionic on my Nanopi Neo2 and would like to install the https://github.com/aircrack-ng/rtl8812au drivers for my Alfa AWUS036ACH. When I choose to compile the dkms modules for the Nanopi Neo2 it fails using this cpu: CONFIG_PLATFORM_ARM_SUN50IW1P1. Is this the correct compila...
mikegleasonjr wrote:
modprobe overlay2 gives me "modprobe: FATAL: Module overlay2 not found in directory /lib/modules/4.4.143"

any way we can run the latest Docker?


https://www.armbian.com/download/?tx_maker=friendlyelec
JAGITA wrote:
There is no forum from Armbian that I can ask question on Fire3.


There is. Here:
https://forum.armbian.com/forum/11-othe ... ed-boards/
Bluetooth is ... problematic. I did have some success with our Bionic desktops and with Cubietruck (which has similar chip) and Tinkerboard ... I could easily connect audio sink to my BT speaker and sound worked instantly. Try Armbian, enable codec (that's support for analog audio which you are tryi...
I solder wires to 2 of the 4 pads on this small board. I test for sound but get none. Edit the "nano /etc/asound.conf" and do aplay /root/Music/test.wav and don't play any sound. I can only set the /etc/asound.conf to card 1 else the aplay will error. What is the right setting to use the ...
Hello, I wish I could add GSM communication to the NanoPi M4 board under Ubuntu. Can you point me to an example that would describe the hardware to acquire and how to configure it ? Cordially Via 4G modem? If it is supported, armbian-config -> enable/disable LTE https://github.com/armbian/config/bl...
toms wrote:
The integrated WiFi will not enter Monitor mode under FriendlyCore. Can anyone tell me the 'chipset' used for WiFi on the T4, or if there is an alternative driver that supports this function.


OOB most of the drivers doesn't support such features.

AP6356S driver (at least on mainline) is brcmfmac
Good... We continue to get the truth about our fees with you) The answer to the technical support for the inclusion of the SPI interface was simple - read http://wiki.friendlyarm.com/wiki/index.php/FriendlyThings_for_RK3399#SPI It says about the Android operating system, and in their opinion, every...
Is there any way to overclock nanopc T4 and can we select which cpu group will be used ? Armbian comes overclocked OOB. You can go a little more, but you need damn good cooling and you risk failures. Default overclock: https://github.com/armbian/build/blob/master/patch/kernel/rk3399-default/overclo...
https://forum.armbian.com/topic/9326-ne ... erboard-s/

The exact same way goes on this board.
I'm also looking to install/use zfs and have been wrestling with the same problem. Tried both the FriendlyDesktop and lubuntu images and both seem to be stuck on 4.4.143 kernel and although I can use the ubuntu kernel upgrade utility to find and "install" different kernels none of them ac...
axd wrote:
Hello. Can you help me please. How to make emmc read only on NanoPi Neo plus2? My file system crashing after hard shutdowns...
Thank you.


Armbian Bionic versions:

armbian-config -> system -> Overlayroot (Enable virtual read-only root filesystem)
Hello, I followed the NanoPi Neo Air setup instructions and my device is starting correctly according to the two LEDs. But I cannot access it via Putty from my Windows 10 PC, it is recognized as "Linux File Store Gadget USB Device". Could somebody please help me, do I need to alter any fi...
There is a lot of cheap 10.1 inches lcd on market, often have a resolution of 1280 x 800. I connected this lcd with h3disp using the mode of 1280 x 720 (720i). Everything works, but aspect ratio is wrong. (800->720) Is there a fast and simply possibility to set 1280x800 resolution in Armbian? Simpl...