Power & Source of Big Ideas

Hi all, I am using this nanopi for different projects without big issues, but since I am going to need to install many boards with the same functionalities, I would like to create an already configured version of the friendly-elec (Ubuntu 16.04.3) to avoid having all the time to first flash it to e...
It was working fine in the older version of Debian, is there no way to transfer that over? Being unable to open an EGL window is a serious restriction for any form of graphic usage Yes, it works in an old kernel and if you need this functionality, you have to forget about kernel 4.x. Currently, tha...
Brian Beuken wrote:
I should also note, that its not possible to update/upgrade, as the repo ip's are not found, I assume it needs no repos set up.


This is usually a sign that something is wrong with your network. You don't have IP address or failed DNS server detection/setup.
I'm on a windows 8.1 machine and tried this on my NanoPi neo, installed armbrian ok, board clearly boots and the LED is blinking and running fine, but no pop up serial console... I've never used a board without a monitor before so am quite confused about how to get connected to it to log in and con...
Hi all, I am using this nanopi for different projects without big issues, but since I am going to need to install many boards with the same functionalities, I would like to create an already configured version of the friendly-elec (Ubuntu 16.04.3) to avoid having all the time to first flash it to e...
The later version of Debian 4.14.0 is unable to initialise an EGL instance, giving a "UMP: ump_arch_open() failed to open UMP device drive" error This seems to be an error in the build rather than any kind of update I can make to it. Is it possible to fix it? This function is not yet deve...
Dear all, I have noticed that new kernel 4.11 has missed support for usb2serial converters like CH340/341 , PL2303 , FT232 ! Older kernel 3.4.y has built-in support for these chips ? has any one experienced this matter ? should I recompile the kernel ? In Armbian is enabled by default . If you need...
Franck.mh wrote:
Hi kicker,

Did you succeed in integrate Mali 400 driver to Kernel 3.4.y ?
I need it for my application.


Works with viewtopic.php?f=42&t=1203
I believe I was mistaken - apparently there is a quick current drop, and based on uptime when I log back in I think it's actually rebooting the Air. Uptime shouldn't reset when waking up from suspend, I would think. https://h3droid.com/chat-with-us Ping KotCzarny - he was playing with this tool and...
Hello, I have a NanoPi Neo Air running the FriendlyCore Xenial 3.4.39_20171102 image. I can put the board into a suspend state using pm-suspend, but cannot wake it back up. Ideally I'd like to be able to wake it up using a GPIO pin as an input. Is this possible? I'm not sure where to start. Thank y...
Hi, I started my nanopi from pendrive containing armbian, upgraded it (which unfortunately also upgraded u-boot apparently) and after rebooting it loops over: U-Boot SPL 2017.11-armbian (Jan 24 2018 - 11:07:32) DRAM: 1024 MiB Trying to boot from MMC2 NOTICE: BL3-1: Running on H5 (1718) in SRAM A2 (...
It reboots properly for me, also with a shield, powered this way: (bootlogs)
P1020275.jpg
P1020275.jpg (143.45 KiB) Viewed 583 times
Update to 4.14.14
I've checked, on armbian (both debian and ubuntu) latest, for now, upgraded and so on, the result is the same. System is not going up after reboot. Debian and Ubuntu are identical in a kernel and u-boot, where is the source of this issue. I actually tested and it worked for me, Duo without a shield...
after reboot command: http://www.friendlyarm.com/Forum/download/file.php?mode=view&id=82 On armbian the same Expected that it will boot then, but nothing happening after that. It will boot just after power off\on Is it just on mine board or everyone has the same ? details: BOARD="NanoPi-Du...
mot1639 wrote:
is there are any advice please


This way:
viewtopic.php?f=48&t=1204&p=3677#p3677

With those images:
https://dl.armbian.com/nanopiduo/archive/
Thanks Igorp. Now, if I understand it correctly, do I just connect the Nano Pi with a microUSB-USB cable to my Mac? (I suppose it should give it enough horsepower to boot up). Once it's up, how do I access it? Previously I was using the USB/TTL cable mentioned above which exposes a /dev/cu.usbseria...
Hi, My Neo Air booted due memory leak of wifi-driver. That happened because scp-filetransfer was running. output of dmesg: [10489.852463] brcmfmac: brcmf_proto_bcdc_query_dcmd: brcmf_proto_bcdc_msg failed w/status -110 [10492.372500] brcmfmac: brcmf_proto_bcdc_query_dcmd: brcmf_proto_bcdc_msg faile...
I have a NanoPi Neo Air (Allwinner H3 SoC) with onboard wifi and a serial interface. Unfortunately during some late hour hacking I managed to accidentally connect 5V onto its TX pin, I think effectively screwing up its UART0. I can no longer connect to it via a USB to TTL Serial cable (https://www....
+ kernel 4.14.39
+ 2GB memory support
+ ethermet works
+ wlan works
+ desktop works
+ mali works
+ cpu scaling works
+ docker support

- eMMC install fails (T3+), BT does not work yet
- power off reboots the board

Images
https://www.armbian.com/download/?tx_soc=s5p-6818
You might want to start here: https://github.com/armbian/build Tested. And you get better results. This is all you need to run: ./compile.sh BOARD="nanopineo2" BRANCH="next" KERNEL_ONLY="yes" KERNEL_CONFIGURE="no" If you want full image - recommended, you need...
The option to activate some hardware via kernel overlays in armbian-config is - as I know - only available in the mainline Kernel (V4.x) version aof armbian. Yes. For old legacy kernel 3.4.y you need to use FEX editor to fiddle with hw config. Also possible to run it from armbian-config but managin...
In armbian, you just need to enable them:
armbian-config -> hardware

hw-config.png
hw-config.png (12.13 KiB) Viewed 555 times


But first start with this - more recent - image(s):
https://dl.armbian.com/nanopineo/Debian_stretch_next.7z
or
https://dl.armbian.com/nanopineo/Ubuntu_xenial_next.7z
So is it the wrong image? You are using some beta image with a beta kernel which will never get an update with an apt update. To be sure that you have a real 1Gb board you need to provide: - hires pictures of PCB, both sides If you indeed have 1Gb board, try this option - download latest Armbian fo...
I noticed higher idle consumption (approx. 1 watt more) and lower clock speeds with Armbian. Is this a problem for a testing kernel? No. Bleeding edge/development kernels are usually broken at some point, regressions are common and they are definitely not optimised. This happens after basic functio...
Boot speed can be a feature (to prevent crashing during boot), coincidence and not necessarily a bug. If you claim it's slow(er), you should analyze this to see if its a bug or a feature. igorp, I feel you misunderstood what I was saying. I did not claim there was a bug. I you take 2 NeoAir's one w...
maurddz wrote:
Hey all,

I am only seeing 512MB Ram and I have a 1 GB board, anything I can do so it sees the rest of the ram? Tried to figure it out but no clue.

Thanks


You must be using wrong bootloader/image. Try correct image https://www.armbian.com/download/
Also I forgot to mention on the NanoPi wiki it says: This means you need to insert this SD card into some Linux computer. Some deskop Linuxes "mount" this removable media (USB keys, SD cards, ...) automatically, on others you need to mount it manually . Than edit referred files, "unm...
I tried it on the NeoAir last night. I liked that it was nicely striped down and lean. however you could clearly see on boot up and shutdown that it was slower than the FriendlyElec image release. If i had to guess why maybe because of the CPU frequency setting, but that is just a guess. Honestly I...
Hello all, I'm trying to change the boot command line parameters on the Nanopi, in order to isolate one of the CPUs. This is pretty straightforward on an x86 machine via the GRUB line: GRUB_CMDLINE_LINUX_DEFAULT="isolcpus=1" However on Arm-Uboot you have to do it with the 'fw_setenv' util...
Anything??? Try if you can make this work: https://www.armbian.com/nanopi-m3/ There, this is supported out of the box . If you have some time and experience, you can try building the image with a modern kernel (4.4.111) on your own. https://github.com/armbian/config - ./compile.sh INSTALL_HEADERS=&...
https://www.armbian.com/nanopi-duo/ Works! If you want kernel 4.14.y switch to a beta repository with armbian-config. ok, thank you I guess, but how does this have anything to do with my post ? Edit: I checked out armbian.com, trying it now on the NeoAir, so fat looks like a great thing. Armbian is...
https://www.armbian.com/nanopi-duo/
Works!

If you want kernel 4.14.y switch to a beta repository with armbian-config.
I was thinking of Armbian too and would actually prefer it (I have an Orange Pi PC running with Armbian for over a year now without issues, great work, thanks!). However, the last time I tried Armbian ethernet did not work and the board did not boot: http://www.friendlyarm.com/Forum/viewtopic.php?f...
I was thinking of Armbian too and would actually prefer it (I have an Orange Pi PC running with Armbian for over a year now without issues, great work, thanks!). However, the last time I tried Armbian ethernet did not work and the board did not boot: http://www.friendlyarm.com/Forum/viewtopic.php?f...
What about those images? https://www.armbian.com/nanopi-m3/ don't boot with this image. armbian add nanopi m3 to kernel 4.x, please add nanopi m3 to friendlycore. https://github.com/armbian/build/commit/caaa9eae10e988deb49f463282aa67cf8382090a You are saying that stock images and armbian images don...
Christos wrote:
Thank you @Maroon5

Also, what its the u-boot repository for this image ?
It is needed too.


You can build 4.4 kernel also within Armbian. Working for me.
https://github.com/armbian/build/commit ... cf8382090a
dorche wrote:
NanoPi M3 with image friendly-core not boot, naybody can help me?


What about those images?
https://www.armbian.com/nanopi-m3/
I am running my Neo Plus 2 with the official Ubuntu image, which was available in July 2017 (kernel 4.11.2), flashed to emmc. Today I noticed there are new official images with kernel 4.14 available for downloading. How can I upgrade to this version? Alternatively, is it possible to backup all my a...
I was able to fix this by mounting the boot partition from the provided xenial sd-card image and examining their boot setup, which includes these two magic lines: fdt addr ${dtb_addr} fdt set mmc${boot_mmc} boot_device <1> "boot_device" is an undocumented (and poorly named?) DTB property....
And scroll down until you get to Boot System from SSD . Does the boot work without a TF/uSD-Card? and does it boot a TF/uSD-Card when inserted? Sounds like a u-boot setting..... Not possible. U-boot must be somewhere - on SD card. On Armbian, this is even more simple (type nand-sata-install) and mo...
Testing Debian stretch based build ...

- network
- usb
- hdmi
- uart console
- emmc
- cpu scalling

https://www.armbian.com/nanopi-m1-plus-2/
Since it's release there has been no new official rom image yet. Whats the holdup ? There is a working Armbian for Duo. Try it and report if you find something not working. It will be fixed ASAP and it will certainly get updates. When using beta development repository, this means you are getting up...
I would also be interested in Linux 4.x support for the NanoPi M3. I'm specifically looking for a board that will support power management and LVDS LCD panels. Would you please check with the vendor to see when they plan to support Linux 4.x? You can try these: https://www.armbian.com/nanopi-m3/ Wo...
Great!

We plan to start actively promoting Debian Stretch when last few bugs are solved. They (known) are cosmetic and affect desktop builds, while CLI should already be fine.
https://www.armbian.com/wp-content/uploads/2015/09/logo_v4.png Base features are working as they should. Use armbian-config to turn hardware features on and off. armbian-config -> system -> hardware (SPI,I2C,UART, AUDIO, ...) Tested with shield board, mSATA drive, wireless, USB ports, audio, ... It...
Nanopi Neo Plus2 is different board and it works partially with normal Neo2 image. https://dl.armbian.com/nanopineo2/Ubuntu_xenial_next_nightly.7z Boot logs with: Nanopi Neo2 http://sprunge.us/XMZG Nanopi Neo plus2 http://sprunge.us/PRUT ... while https://dl.armbian.com/nanopineoplus2/Ubuntu_xenial_...
q-bert wrote:
Great news!

Is NEON and AES encryption/decryption enabled on this build?


It should be. If you need anything special and we forget to add:
https://github.com/armbian/build/blob/m ... ext.config

Welcome to push changes.
I have noticed strange problem with ap6212: when some device is connected to NanoPi M3 on Bluetooth, Wifi speed drops dramatically. When Bluetooth is off, I have WiFi speed about 2 MB/s. When Bluetooth is turned on, WiFi speed drops slightly, although it is still acceptable... But when some Bluetoo...