Power & Source of Big Ideas

6) then I tried "sudo putty", serial connection with /dev/ttyUSB0, speed: 115200 it opens up a terminal window but it's blank and nothing happens. i'm quite lost. i don't know how to connect to the Nano Pi with a serial cable. oh how i regret messing around with those network settings to ...
sami wrote:
AP6212 Module

Nope ;) the AP6212 is on the NanoPi R1 only - the NanoPi R1S has a Realtek-Module on the picture
(see attached)

WiFi_R1_R1S.jpg
WiFi_R1_R1S.jpg (73.73 KiB) Viewed 222 times
1. does this work with Nano Pi R1? I see Nano Pi has "UART x1: 2.54mm pitch 4-pin-connector". I guess same size as this. 2. can i fix my problem from serial console - flash eMMC? 1.) The NPI R1 (not the new R1S) has the same 2.54mm Pinout as the Neo/Neo2 - should work. 2.) maybe you dont ...
... to use the power LED as a "General Morse Code Display" as a primitive form of visual interface, so it can be used for small short "messages"... for turning LED steady on: echo 'default-on' > /sys/class/leds/nanopi:blue:status/trigger for turning LED off: echo 'none' > /sys/c...
Is there infos about how it works and perhaps how to disable it and use the LED for other purpose? for using it as HDD-Led for the scard (mmc0) use: echo ' mmc0 ' > /sys/class/leds/ nanopi:blue:status /trigger for turning it off: echo ' none ' > /sys/class/leds/ nanopi:blue:status /trigger other op...
Thats OK - this is the "Heartbeat" Signal
Because the pictures are very small, I cant see the number of the Realtek Wifi-Module chipset. FriendlyElec does state armbian-support on the webpage, but the is only armbian for the NanoPi R1 without S, which does have another WiFi-module? Can we get better/bigger pictures and informations about th...
with armbian the PCM5102A hat is working with
mainline kernel 4.19
AND
dev-kernel 5.3.3

I used the debian buster version of armbian for that ;)

see:
https://forum.armbian.com/topic/9009-in ... d-dev-533/
check the page
http://wiki.friendlyarm.com/wiki/index.php/NanoPi_Duo2

there you could see on the upper left 2 Pins for +5V IN/OUT (5V VDD) and then after the 3.3V (OUT-Pin - do connect nothing to this) is GND = Minus/earth
Duo_pinout2-02.jpg
Duo_pinout2-02.jpg (202.7 KiB) Viewed 2517 times
download the mainline-image https://dl.armbian.com/nanopineo2/archive/Armbian_5.91_Nanopineo2_Debian_buster_next_4.19.59.7z or dev-image https://dl.armbian.com/nanopineo2/nightly/Armbian_5.98.191006_Nanopineo2_Debian_buster_dev_5.3.3_minimal.7z unpack it with 7ZIP and write it to MicroSD-Card with e...
ProDigit wrote:
Hi!
What's the best option to connect a monitor to the Zeropi?
I have either a USB monitor, or a monitor with HDMI or VGA connection.

because there is no VGA/HDMI you could only use USB or a remote-desktop session (RDP/VNC/SSH)
you could try some "unofficial" self-build armbian (like a pine64 fork) where eth0 & wlan0 does work: https://forum.armbian.com/topic/9308-experiment-armbian-on-nanopi-a64/ (you need a small .dtb/.dts-tweak for getting the upper usb-port working) armbianmonitor -u System diagnosis info...
Information here: https://www.friendlyarm.com/index.php?route=product/product&path=69&product_id=266 and http://wiki.friendlyarm.com/wiki/index.php/ZeroPi and https://www.cnx-software.com/2019/09/05/zeropi-allwinner-h3-sbc-gigabit-ethernet-spi-flash/ I dont understand why FriendlyARM doesnt ...
rvalvekar wrote:
Thanks..


got this also on some new installations of armbian ;)

try
ps -ef|grep apt

If there is only the task of this command for apt then you could apt again - if there is more you should wait to let the installation be completed.
I only have such weird dmesg-messages (because the LicheePi uses OTG and switches his USB behaviour), when I power/connect my LicheePi Zero via the Neo2 USB port: [294267.541980] usb 5-1: new high-speed USB device number 28 using ehci-platform [294267.889945] usb 5-1: device descriptor read/64, erro...
Continuing: I've read the 2 top links guidol provided (the bottom 2 were broken links/non-existent) as per link, need to add the line OK, I had two links in only line :( here the two again: https://zeldor.biz/2010/12/unable-to-enumerate-usb-device/ https://paulphilippov.com/articles/how-to-fix-devi...
there seem to be problems with the device on port 3-1: [ 2.637111] usb 3-1: device descriptor read/64, error -71 [ 3.089093] usb 3-1: device descriptor read/64, error -71 [ 3.877094] usb 3-1: device descriptor read/64, error -71 [ 4.329091] usb 3-1: device descriptor read/64, error -71 [ 5.505091] u...
should not happen to NanoPi Neo2 No2, because I got 2 old Neo2 running ove a year and a LTS Neo2 1GB Ram now runjing for about 6 months.
how about openwrt-18.06.1_sunxi-cortexa7_prebuilt_20190109.tar.gz https://drive.google.com/open?id=1PHtHLgQ-5rmlHlkLbdGbkU2Ss8ezgXDf nanopi-r1_sd_openwrt_4.14_armhf_20190117.img.zip https://drive.google.com/open?id=1Bt2YVhXCvhlnfzXfMmeZYZpFrMh3dRbb nanopi-r1_eflasher_openwrt_4.14_armhf_20190117.img....
LTolledo wrote:
Could be the SoC already?

or the ethernet-cable or port of the cable?

Did you swap against another port/cable and double-check if there is no double IP?
from where did you "git clone"?
for the other NanoPi's are here the instructions:
http://wiki.friendlyarm.com/wiki/index. ... ld_OpenWrt

or download compiled OpenWRT (SD or eflasher) from here:
https://drive.google.com/drive/folders/ ... GkfijH0frC
some time ago I searched about performance-fine-tuning the /etc/samba/smb.conf and ended up with the following parameters in the [global] section: [global] workgroup = GUIDO server string = %h server hosts allow = 192.168.6. log level = 1 log file = /var/log/samba/log.%m max log size = 1000 syslog =...
Compiling an OS need courage :) I was looking for a finalized version which is stable and well tested. I have no experience with compiling Linux system. I read the thread you sent me and seems that you got a working version but with some patches. is that something I can trust for a product deployed...
The other os images you suggested, are they stable? and is there a minimal OS without UI image? if you want it stable and headless - try to compile a actual version of armbian as experiment (should also work with normal maninline and not only dev-version): https://forum.armbian.com/topic/9308-exper...
I only know the "old" FriendlyCore image at https://drive.google.com/open?id=1n73b3H7jGJ8T9XdFno6GK_X8TZ6RTcBN or Ubuntu from the user avafinger https://github.com/avafinger/nanopi-a64-firmware or as experiment a "headless"/server-version of a actual armbian ;) https://forum.armb...
manually I did only use fdisk and resize2fs like: normally (when moving manually from a small to a bigger sdcard) İ do the following: fdisk /dev/myospartition d for delete the partition n for new primary partition set size to 95% of the max sector/cluster set partition type to 83 linux (leave ext4 m...
mackowiakp wrote:
Can I safely remobe *.deb files from "/" dir?


normally you could safely remove any *.deb from /
because they should reside in
/var/cache/apt/archives/
1. Is there a ready image and if so where can I download it? 3. How do I burn an image on a microSD I know ... how to burn an .img image to eMMC from under Linux using an adapter http://www.friendlyarm.com/index.php?route=product/product&path=83&product_id=208 ? The official FriendlyArm-And...
The problem with both the Armbian and DietPi is they don't have support for the 5102A Audio Hat. but YOU can enable armbian to support the 5102A Audio-Hat :) with my instructions :) My Neo can use it! https://forum.armbian.com/topic/9009-info-friendlyarm-pcm5102a-hat-with-nanopi-neo-under-mainline-...
Neo4 Wiki page does say there IS a combi-module:
http://wiki.friendlyarm.com/wiki/index.php/NanoPi_NEO4
Wi-Fi/BT: 802.11 b/g/n, Bluetooth 4.0 combo module
tw1145 wrote:
Why stop at 128GB?


maybe because they only tested the Duo2 "only" with up to 128GB:
http://wiki.friendlyarm.com/wiki/index. ... _We_Tested
thanks for the reply. as I can see it the max frequency is capped to 816MHz on this NanoPi Neo2 v1.0 running the latest armbian stretch. can this be changed? the 1.01.Ghz (or 1.08) are from my Neo2 LTS v1.1 (1GB Ram) as I did see now. My two Neo2 v1.0 (512MB) are also capped to 816Mhz in armbian, b...
when you use cpufreq-info (without a -p) then you could should read: hardware limits: 120 MHz - 1.01 GHz available frequency steps: 120 MHz, 240 MHz, 480 MHz, 648 MHz, 816 MHz, 960 MHz, 1.01 GHz available cpufreq governors: conservative, userspace, powersave, ondemand, performance, schedutil current...
on the wiki page
http://wiki.friendlyarm.com/wiki/index.php/NanoPi_M4
they named the standard 40 pin Connector GPIO1 because of the additinal ports on the 24 pin row GPIO2 :(
maybe they want to sell the new Duo2 with 512MB?
https://www.friendlyarm.com/index.php?r ... uct_id=244

maybe the Duo2 is useable with an apdapter in your pcb?
igorp wrote:
JAGITA wrote:
I would like to purchase this WiFi Transciever on Mouser

But it will not work.

the user JAGITA does only copy questions from other users (like here from the Thread-opener "oneCuil")

JAGITA did this in 20 posts and did not wrote a own sentence - I did report him to FriendlyElec.
https://www.friendlyarm.com/index.php?r ... uct_id=248

but why FriendlyARM didnt do write here about it as News?

Wiki for the R1
http://wiki.friendlyarm.com/wiki/index.php/NanoPi_R1
ayaromenok wrote:
- win10 on RPi is not a typical desktop\arm64 windows 10 with GUI

since (?) a week ther is a solution for GUI - but VERY slow on the Raspberry - but not on a NanoPi:
https://www.tomshardware.com/reviews/in ... ,5993.html

I think that is what the Thread-Owner mean :)
because your Username is ISTANBUL maybe you are from there? :) Then Iam near you - in Mudanya near Bursa - and we also often have power outages here, but my 10 SBCs are mostly running armbian as OS and no one - by now - had a bootdevice-corruption ;) Maybe you can try to use armbian on your T4?: htt...
I dont know about the wiki-entry, because my Duo hasnt a SSD :(
I only did remember what I did read in the past...
I also got no eth0 in /dev on another SBC, but eth0 is working.

You could try to expand eth0 in /etc/network/interfaces:

auto eth0
allow-hotplug eth0
no-auto-down eth0
iface eth0 inet dhcp

how about:
dmesg|grep -i eth0

or if the ethernet-module/driver has been loaded:
lsmod
did you try " sudo ifconfig -a " if there is any eth0-device? you can also check the output of " dmesg " if there are any errors about LAN/GSM. Did you check within " npi-config " if there is any hardware disabled which can be enabled? If eth0 could found with "ifc...
I get the same issue on mine as well. Wish they would fix it already as I have told them about this months ago. As I remember FriendlyARM wrote in some forum-thread that the eMMC on the "breakout" board of the NanoPi Duo was never supposed to be a bootable device.... They wrote is should ...
which port (UART/WiFI/Ethernet?) do you use for the console? Did you insert the Duo2 the right way to the box-board? Do you power the box board via MicroUSB-Port? (is the Duo2 powered from the box-board?) Did you switch on the box-board? Wiki: http://wiki.friendlyarm.com/wiki/index.php/NanoPi_Duo2 h...
you could try to switch they off like in the following sample (use the led-names of the Neo4 if available): root@npi-neo2-23(192.168.6.23):~# cd /sys/class/leds root@npi-neo2-23(192.168.6.23):/sys/class/leds# ls -l insgesamt 0 lrwxrwxrwx 1 root root 0 Jan 1 1970 nanopi:green:status -> ../../devices/...
Raymond Day wrote:

root@NanoPi-NEO-Air:~# ifconfig wlan0 up
SIOCSIFFLAGS: Operation not permitted
root@NanoPi-NEO-Air:~#

How do I fix that?

try
sudo service networking restart
or check
http://pkadetiloye.blogspot.com/2010/11 ... flags.html
But I am trying to get it to work with squeezelite I don't get why it's not listing the Pcm5102a,DEV=4 root@NanoPi-NEO-Air:~# squeezelite -l Output devices: sysdefault:CARD=I2Smaster - I2S-master, - Default Audio Device root@NanoPi-NEO-Air:~# isnt that device-name useable without device-numer? in t...
whats the output of aplay -l and what is the content of your /etc/asound.conf ? Sometimes after installting the pcm5102a - in mainline armbian - and reboot my pcm5102a changed from Card 0 to Card 1: root@npi-neo(192.168.6.24):~# aplay -l **** List of PLAYBACK Hardware Devices **** card 0: Codec [H3 ...