Power & Source of Big Ideas

Hi bluescape, Long time no hear. Don't work on the FA stuff any more so don't check-in very often. What distro are you running on the Mini2451? I used the process as described on the Armworks site. To your problem ... the only thing I can suggest is checking the attributes at /dev/ttySAC0 I ran an L...
Has it got a UART port that you can plug something like the PSU-ONECOM into and look at the boot messages?
Maybe look through the old forum http://www.friendlyarm.net

Also, Google <mini2440vietnam> for tutorials and qmake.conf
The mini2440 used a cross-over ethernet able.

Good work!
SuperVivi ... boy we are going back about 10 years. It was used an early bootloader on the mini2440. However, at that stage a program called dwn.exe which you ran on a Windows PC was used . To quote "what you have done is load the min2440 NAND boot with the SuperVivi file loader program". ...
Grab the schematic for your specific Nano and trace the 5V switching circuit output to your USB connector. The units I have worked on have the USB supply directly connected to the 5V switch-over circuit. So, with a hardware mod you might be able to switch the USB 5V supply line on and off. I have ne...
So there should be no problem with USB. Not too sure what this comment means. If it did use a USB to ethernet bridge and specifically USB 2 then the ethernet speeds might be lower than a proper ethernet implementation. I would assume USB would not be affected in this case or if a proper ethernet im...
If it is working I would doubt extra parts can to be added to increase the speed. I have read discussions about Ethernet speeds on various boards, so I would focus on what an NEO that comes with that port is capable of. I believe some SBC (single board computers) use the USB bus to handle the ethern...
One way to do it is in /etc/rc.local before the exit 0 line place:

Code: Select all

rfkill block bluetooth


You could try:

Code: Select all

rfkill block wifi


I haven't tried stopping Wifi.

Good luck!
FriendlyArm's PSU-ONECOM

Good chance your NEO's UART has been damaged.
Had to Google <serial port inverted> seems a few people have had this issue. However, I went back and re-read your original post ... specifically about how you are wiring these two units. As far as I am aware a DB9 connector on a PC is a real RS-232 item, ie voltage levels like +/-15 Volts and you c...
And the baud rate? Try 115200
So, we can conclude that /etc/rc.local gets at least partially executed, correct? Wikipedia says: Bourne-style shells allow standard error to be redirected to the same destination that standard output is directed to using 2>&1 Thought that >&2 was not what I wanted to get you to try. So, now...
Either trying to echo stuff in init.d files is not done as per my suggestions or I wonder if any of the init.d scripts are running. Next thing I would try is ... #!/bin/bash echo "abc runs" > &2 echo "abc runs" > /dev/tty1 and call it abc and place this in /etc/init.d and giv...
A really good place to get help for general Debian operating systems is at http://www.raspberrypi.org/forums/

I recall some discussion about rc.local there:
https://www.raspberrypi.org/forums/viewtopic.php?t=95101
looks relevant.
In /etc/init.d/rc.local place the following: echo "/init.d/rc.local runs" >&2 echo "/init.d/rc.local runs" >/dev/tty1 In /etc/rc.local place the following: echo "rc.local runs" >&2 echo "rc.local runs" >/dev/tty1 and see if any messages are printed on ...
The rc.local file in /etc/init.d/ on a Debian installation looks like this: #! /bin/sh ### BEGIN INIT INFO # Provides: rc.local # Required-Start: $all # Required-Stop: # Default-Start: 2 3 4 5 # Default-Stop: # Short-Description: Run /etc/rc.local if it exist ### END INIT INFO PATH=/sbin:/usr/sbin:/...
Also going back to your 2nd post on the 5th Mar similar code is found in /etc/init.d/ on my Xubuntu machine. Which then goes and looks at /etc/rc.local for further information.

Exactly where are you placing your "rc.local" file?
Seems

Code: Select all

sudo chmod -x /etc/rc.local

is the way to stop it executing.

Are you sure your new rc.local is 755?
The next things I would try: - move your existing /etc/rc.local to your /home directory for safe-keeping - put your new rc.local in /etc/ - and re-boot I didn't pick up on the sh versus bash issue. All my scripts use bash, Google for the differences. As far as I am aware all scripts in /etc/init.d/ ...
Hang on a minute ... if you have a /etc/rc.local and you try to run another /etc/rc.local (placed in /etc/init.d/) when you boot up how does it know which one to run?

Or, did you name it something different and place it in /etc/init.d/
I am confused about "typing it in the command line". I meant put all the text into a file, call it my_test_script.sh and run it like so: sudo ./my_test_script.sh from the same directory that you created it in. sudo chmod 755 The next thing I would try is: sudo service rc.local start It ran...
First I would make sure that you can execute it as a stand-alone Bash script. That will possibly point to a file permissions problem.

How does the /etc/rc.local file get executed in the first time? Have a look in /etc/init.d
Is there a rc.local file in there?
There is a "bare metal" subsection on the RaspberryPI forums that should deal with the topics and processes that you need to understand and use.
In some of the older NanoPi one had to place a rootwait/rootdelay arg in the boot environment variables, when booting from an SD card. I'd have to try and find the details. https://unix.stackexchange.com/questions/67199/whats-the-point-of-rootwait-rootdelay Do your boot messages provide any clues wh...
Ah, an observation ... after flashing the microSD card I have one folder called NANOPI and another one called NANOPI1, both with the same contents. Perhaps on booting the system init doesn't know which rootfs to use. When I was playing with Matrix on the original NanoPi I had something similar happ...
Just realised that there was something else. There was a selection in my kernelconfig for serial USB which needed to be enabled and re-compiled.

Perhaps investigate whether or not you need to do that.
Are you sure there is no serial number?

ATTRS{serial}=="12345"

I ran two Teensy 2 boards and in the Teensy software I had to change the serial (number) so that I could talk specifically to one device.
Looking again I see it goes in /lib/udev/rules.d not rules. You probably picked up that error. I just fired up the old mini2440 with the Teensy 2 board and I get: crw-rw-rw- 1 root dialout 166, 0 Jan 1 13:00 ttyACM0 and for the rules file: -rw-r--r-- 1 root root 1982 Feb 28 2015 49-teensy.rules I ca...
Sounds familiar to using a Teensy board on my old mini2440 system. I think all that was required was 49-teensy-original.zip Rename it 49-teensy.rules This gets placed in /lib/udev/rules It would need modifying. Are you sure there is not a suitable udev rule floating around somewhere? Good luck! Dave
You would probably find some helpful messages if you are running a terminal program like minicom while connected to the debug or UART port using something like the PSU-ONECOMM.
I have not used any of the 6410 variants, but I would think if it has a UART interface that you should be able to connect to it and program it. If it does have a UART interface be aware the correct voltage levels. Then you should be able to refer to the mini6410 documentation to learn how to program...
OK, lsmod was not helpful.

You didn't say which board you are working on. Also, I don't recall of anyone running Ubuntu on these boards. I ran Debian Jessie on the NanoPi for a year or so.

Have you tried:

sudo apt-get install iptables
lsmod, ie list modules ... not ismod
What does lsmod say?

Which board are you working on and what OS?
You are lucky it was a common problem.. I would suggest that you search the old site http://www.friendlyarm.net/forum . The original FriendlyArm distro for the 6410 should have a working ts_calibrate in it but looks like someone has made some modifications. ts_config is a 4 or 5 line text file. Try ...
You would connect with ifup wlan0

Show us your /etc/network/interfaces file and /wpa_supplicant/wpa_supplicant.conf
"Live and learn". Geany became my default "editor" after my last Xubuntu upgrade instead of gedit. Now I know it is more capable than I first thought. Seeing as your issue is totally related to Geany use I would suggest looking around for a Geany forum or a Geany Wiki where they ...
Running logrotate in a cron job doesn't work
?
Is a question not a statement.

I have a cron_error.log file in my home directory where I would expect any cron errors to appear. I don't run logrotate so can not help with the details.

Post your cron file, maybe I will see somethng.
Ah, you do have a makefile but you are not using it? Also, it looks like you are working with the Matrix or BitBake tools. I am confused by your reference to Geany. I am sure it is just an editor not an IDE, correct me if I am wrong as I actually use it as an editor only. I have done some matrix stu...
Show me the contents of:

geany_run_script.sh

Where did you get the script from? How did you find gpio.c ? Looks like it is part of a package that you don't have all of the files. WiringPI or the FriendlyArm version?
Yes, at the top of the .c file you should see #includes all you need to do if find out where those files are and make sure they are in the location pointed to. If the .h file is enclosed in " " then they should be in a local folder with your .c file. If you are compiling from the command l...
davef wrote: Last things first ... have you more than one .c file that you are trying to cross-compile? If you are trying to cross-compile more than one .c file on the command line you need to something like: arm-linux-gnueabihf-gcc -Wall PB.c 1wire.c gpio.c adc.c -o PB ... unless you want to learn...
Tag_CPU_arch: v7 Is the line you are after. I don't know which arm version your board uses, so you will need to search around for that. Have you been able to cross-compile any programs for your target? Looking back at your original post I would have not expect you to call "gcc" but someth...
Last things first ... have you more than one .c file that you are trying to cross-compile? ./geany_run_script.sh: . . . Did you try running like this: sudo ./geany_run_script.sh Geany is an editor, it has nothing to do with the cross-compile process. Do you get anything when you drop (Program exited...
Well I am a bit puzzled about how things are operating at your end. The guru at Pengutronix actually made a custom .make and .in file so that I could install PHP with thpptd enabled. Sorry my Pengutronix BSP computer is in another location and I won't be back there for a week or more. I could then t...